PHP

PHP ist eine weit verbreitete Web-Skriptsprache für die Erstellung dynamischer Webseiten. Viele beliebte Web-Anwendungen wie z.B. Blog/CMS (Wordpress, Joomla, Typo3 etc.), Foren oder Shop-Systeme basieren auf PHP.


Inhalt


PHP - aktuell und in Zukunft

PHP-Version

Um für die verschiedenen CMS- und Shopsysteme in Ihren verschiedenen Versionen, die größtmögliche Kompatibilität zu erreichen, stehen unseren Kunden direkt mehrere PHP-Versionen zur Auswahl:

PHP-Version Verfügbar
7.4
7.3
7.2
7.1
7.0
5.6

Grundsätzlich empfehlen wir die Verwendung der jeweils aktuellsten PHP-Version.

verwendete PHP-Version

Über LiveConfig haben Sie die Möglichkeit, für jede Domain bzw. Subdomain die verwendete PHP-Version individuell zu hinterlegen. Lesen Sie hierzu bitte unseren Artikel zu PHP.

Wir empfehlen, die jeweils neueste und somit aktuellste Version einzusetzen: ältere Versionen werden nach vorheriger Ankündigung außer Betrieb genommen!

von PHP 5.6. zur neueren PHP-Version

Erfragen Sie zunächst beim Hersteller der eingesetzten Software, ob Ihre Software-Version und zusätzlich installierten Komponenten, Module oder Plugins, mit den neueren PHP-Versionen (7.0 oder höher) kompatibel ist.

Darüber hinaus können Sie auch direkt über LiveConfig testen, ob Ihre Webanwendung auch mit einer höheren Version von PHP umfassend und fehlerfrei funktioniert. An dieser Stelle möchten wir Sie noch einmal auf unsere Anleitung verweisen.

Inkompatibilität

Falls die von Ihnen eingesetzte Software nicht mit den neueren PHP-Versionen (5.6 oder höher) kompatibel ist, prüfen Sie bitte, ob es eine neuere Version Ihrer Software gibt, welche die aktuellen PHP-Versionen unterstützt. Setzen Sie sich hierzu ggf. mit Ihrem Webmaster oder Ihrer Agentur in Verbindung.

Bitte haben Sie jedoch Verständnis dafür, dass wir Sie bei eventuell notwendigen Anpassung von Skripten nicht unterstützen können.